Issue with generating time/fee entries and invoices
Incident Report for Smokeball Australia
Resolved
This incident has been resolved.
Posted Jul 19, 2023 - 17:46 AEST
Investigating
We are currently investigating an issue with Smokeball Billing where the system is experiencing delays in generating invoices and recording time, fees, and disbursement entries.
Posted Jul 19, 2023 - 16:01 AEST
This incident affected: Smokeball Billing.