Delayed syncing in billing, matter data and AutoTime entries
Incident Report for Smokeball Australia
Resolved
This incident has now been resolved.
Posted Nov 14, 2023 - 19:51 AEDT
Update
A fix implemented earlier today has resulted in notable improvements in throughput to our servers.

Matter data should behave normally, though you may notice some ongoing issues with saving or syncing invoices, or billing data. We expect these to recover fully in due time, and we will continue to monitor closely.

Thank you for your patience as we work on a solution.
Posted Nov 14, 2023 - 19:01 AEDT
Monitoring
We are currently implementing a fix to increase the data capacity moving towards our servers. As the fix rolls out, it will make data move much faster and be back in sync.
Posted Nov 14, 2023 - 16:54 AEDT
Update
The team has identified the root cause of the issues causing delays to our database, and are working on a fix with priority.

You may notice continued issues with saving or syncing matter data, invoices, or billing data in the meantime.

Additionally, any changes to billing or matter data may take longer than usual to save or sync back to our servers.

Thank you for your patience as we work towards a resolution.
Posted Nov 14, 2023 - 14:29 AEDT
Update
We are continuing to investigate this issue.

You may notice issues with saving or syncing matter data, invoices, or billing data. Additionally, any changes to billing or matter data may take longer than usual to save or sync back to our servers.

Thank you for your patience as we continue our investigation.
Posted Nov 14, 2023 - 12:25 AEDT
Investigating
We are currently investigating delays in syncing billing data and some matter data (party roles/relationships). This issue has also caused a delay in last night's AutoTime processing.
Posted Nov 14, 2023 - 09:59 AEDT
This incident affected: Smokeball Billing and Smokeball (Matter Syncing, AutoTime).